Linux-y Zandronum keyboard input bug(s)

So, I'm a keyboard DooM player. I've been that way since the beginning of me playing DooM because, well, I have a very simple mind that can't really handle two input devices at one time such as keyboard AND mouse.

Some time ago, this year though, I noticed while testing levels I was authoring that I would stop moving forward and have to take my finger off of the forward (up) arrow on the keyboard and put it back down in order to move again.

When I noticed this, I tried the same thing on my Windows XP development box and did NOT have this issue there. That XP machine's test setup is with Zandronum 2.1.2. I thought maybe was issue only with newer Zandronum as the version I was using on my main Linux machine was 3.01. So I downloaded and installed Zandronum 3 on that Windows XP box. The keyboard input problem does not exist using Zandronum 3 on Windows either.

Okay, I thought, maybe it's my crappy Linux install. I was running MX-Linux for about five months and it had all kinds of "little" issues the entire time I ran that OS. Last month, I wiped the hard drive clean and did a fresh install of Linux Mint. I think there was then some funny issue with getting sound to work and from the things I was able to glean off of the Zandronum forums, I found that it was a problem which is already documented and the temporary fix is for me to run Zandronum 3.1 Alpha. Great that I can do testing of my own new levels with this. Unfortunately, because I'm running this alpha, I'm no longer able to join in any deathmatch online games on The Sentinel's Playground due to the version checking their servers do. Oh well, eventually 3.1 will be the version they're running.

Well, new Linux OS, newer version of Zandronum, same keyboard input problem. Just for giggles and grins, I thought I'd see if it was the actual machine's fault. I installed both ZDoom and GZDoom to test for the bug, which does NOT exist in either port.

So now I've put together a little WAD file to test for this bug. It can be downloaded from HERE

I'd put markers on the wall every ten doomscale squares, e.g.; 10, 20, 30, etc. But found that if I just hold the up arrow key down and go straight ahead, I'm able to reach the end of my silly hallway without issue. It's only when I've "steered" at least once by simultaneously tapping left or right arrow keys that the forward motion eventually gets stopped. Once again, I've tested this test WAD file with ZDoom and GZDoom and they don't exhibit this behavior.

But it gets even better! I'd remembered having input issues with firing as well. So, at the end of my dumb little hall, I added a backpack FULL of ammo as well as chaingun, plasma repeater and corresponding ammo for these weapons. And testing yielded the keyboard bug nearly immediately! Hitting no other key on the keyboard, I depress the left CTRL key, which is set to fire on my system, and I looked at the ammo inventory numbers tick down until they stopped. On the chaingun, that would be fourteen (14) shots. Once again, I loaded the silly test WAD file into GZDoom and ZDoom ~ no problem in those ports with repeated firing by holding down the CTRL key; I'm able to completely blow through the allotment of 400 bullets or 600 plasma shots with the plasma repeater gun.

What say you Zandronum maintainers? I love you guys!!

Robotron INDUSTRIES